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 Learning Objective🎯

In this lesson, students will explore different control modes in robotics through the multiple 
communication systems integrated into the Pedro robot. It is strongly recommended to complete 
Lesson n°1 « Discover Robotics by Building Pedro » before starting this activity. This lesson 
introduces students to various robotic communication methods using Pedro’s control modes, 
including:

 Manual Mode
 Record & Replay Mode
 Radio Mode
 USB Serial Mode
 Bluetooth Mode

 Instructor Notes👨‍🏫

 Recommended age: 12 years and older
 Ideal for STEM clubs, classroom workshops, or science projects
 Students should have basic computer literacy
 Duration: ~2 hours

  Required Materials🧰

Item Quantity Description

Pedro Robot Full Assembled 10 units 1 robot by student

Oled Screen 128x64 1 unit Screen to naviagate through Pedro menu

Module NRF24L01 1 unit Radio communication

Module HC-05 1 unit Bluetooth communication

Micro USB cable 1 unit USB communication

 Final Activity🧩

At the end of the workshop:

 Students complete a 20-question quiz to review key concepts.
 Teachers can discuss real-world applications of robotics and 3D printing.

2 / 13
Pedro STEM Lesson n°2                                                                                                                   https://pedrobot.com

https://pedrobot.com/


Table of Contents
 Learning Objective🎯 ......................................................................................................................... 2
 Instructor Notes👨‍🏫 .............................................................................................................................. 2
 Required Materials🧰 .........................................................................................................................2
 Final Activity🧩 .................................................................................................................................. 2

1. Pedro Firmware Setup...................................................................................................................... 4
2. Control Modes.................................................................................................................................. 5

2.1 Manual Mode.............................................................................................................................6
2.2 Record & Replay Mode............................................................................................................. 7
2.3 Radio Mode................................................................................................................................8
2.4 USB Serial Mode....................................................................................................................... 9
2.5 Bluetooth Mode.......................................................................................................................10

3. Quiz (20 Questions)........................................................................................................................11

3 / 13
Pedro STEM Lesson n°2                                                                                                                   https://pedrobot.com

https://pedrobot.com/


1. Pedro Firmware Setup

The Pedro Firmware is the main program that powers and controls the Pedro robot.
It allows students to explore multiple control modes all within a single program to better understand 
how robots receive and execute commands.

1. Download and install the latest version of the Arduino IDE. 
2. Install the required libraries from the Library Manager: 

 PedroRobot: Tools → Manage Libraries → search PedroRobot → Install 

 U8glib: Tools → Manage Libraries → search U8glib → Install 

 RF24: Tools → Manage Libraries → search RF24 → Install 

3. Insert the Oled Screen into the Pedro board and Connect the board to your computer via USB. 
4. Select the correct port: 

 Tools → Select the port that appear when you connect Pedro robot 
5. Select the board type: 

 Tools → Board → Arduino Micro 
6. Open the example sketch: 

 File → Examples → PedroRobot → Pedro 
7. Compile and upload the sketch to your Pedro board. 

 ✅ If everything is correct, Pedro’s OLED screen will display “MANUAL MODE”.

Programming and embedded systems concepts will be covered in   Lesson 2  , where you’ll learn how the   
board operates and interacts with coding instructions.
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2. Control Modes

Using the 128x64 OLED display, users can easily navigate through the menu to select and configure 
different modes of operation.

The available control modes are:

 Manual Mode – direct control using onboard buttons
 Record & Replay Mode – record and replay movements
 Bluetooth Mode – control Pedro via smartphone or PC
 Radio Mode – remote communication between robots
 USB Serial Mode – control Pedro directly from a computer

Through this firmware, students discover how software can define robotic behavior and how multiple 
communication interfaces can coexist within one system. The picture below described how to navigate 
through the multiple control modes.
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2.1 Manual Mode

What it does: Direct control of servo motors using onboard buttons.

How to use:

1. Power ON Pedro (default mode Manual). 
2. Press the button A0 to select the servo.

The LED corresponding to the selected servo light on. That button allows you to control each 
part of the robot. 

Here is the mapping between the LED ID and the servo ID :
 LED D13 → servo D5 (Base)
 LED D11 → servo D6 (Shoulder)
 LED D8  → servo D9 (Elbow)
 LED D7  → servo D10 (Gripper)

3. Use button A1 to Move Servo to Left. 
4. Use button A2 to Move Servo to Right. 
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2.2 Record & Replay Mode

What it does: Record servo movements, then replay them.

How to use:

1. Enter the Select Mode menu (hold button A0 for 4 seconds). 
2. Choose Record Mode from the menu. 
3. Press A0 to confirm. 
4. Move Pedro manually using the buttons (as in Manual Mode). 
5. Re-enter the Select Mode menu (hold A0 for 4 seconds). 
6. Select Replay Mode. 
7. Pedro will now repeat the recorded sequence in a loop. 
8. To stop or change, re-enter the Select Mode menu. 
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2.3 Radio Mode

What it does: Enables remote communication between two Pedro robots or more using the 
NRF24L01 radio module.

How to use:

1. Insert the NRF24L01 module into the left 
slot of each Pedro board (one robot as 
transmitter, the other as receiver). 

2. Set Pedro’s switch NRF → BT → WiFi to: 
NRF. 

3. Power cycle your board (turn it OFF and then 
ON again).

4. Enter the Select Mode menu (hold button A0 
for 4 seconds). 

5. Choose Radio Mode from the menu. 
6. Press A0 to confirm. 
7. Define the robot’s role (type): press A1 to 

select TRANSMITTER or RECEIVER. 
8. Press A0 to confirm the role. 
9. Set a communication Code Key: 

 Press A1 to increase (increment)
 Press A2 to decrease (decrement)
 Values range from 1 to 99

10. Press A0 to confirm the Code Key.
11. Press A0 again to validate (OK). 

💡Note: Both the transmitter and receiver must use the same Code Key to establish communication.
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2.4 USB Serial Mode

💡Note: For this mode, you must use a compatible browser such as Chrome, Edge, or Brave on 
desktop. Chrome has been successfully tested with this application.

What it does: Control Pedro from your PC with web controller app.

How to use:

1. Enter the Select Mode menu (hold button A0 for 4 seconds). 

2. Choose USB SERIAL MODE from the menu and press A0 to confirm. 

3. Connect Pedro via USB cable. 

4. Launch the web controller (https://www.pedrobot.com/webcontroller.html) app. 

5. In the web controller click, the « Connect Pedro » button.
6. Select the corresponding Pedro serial port.

7. Click the « Servo N » button to select a servo.
The LED corresponding to the selected servo lights up. That button allows you to control each part of the robot.

8. Use the « Left » button to move servo to the left. 

9. Use the « Right » button to move servo to the right.

10.   Use the « Stop » button to stop the movement.
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2.5 Bluetooth Mode

What it does: Control Pedro via smartphone or PC.

How to use:

1. Download the Serial Bluetooth app (iOS or Android). 
2. Create 7 control buttons with the following configuration: 

 Name: Servo1 → Value: 1 → Mode: Text → Action: Send. 
 Name: Servo2 → Value: 2 → Mode: Text → Action: Send. 
 Name: Servo3 → Value: 3 → Mode: Text → Action: Send. 
 Name: Servo4 → Value: 4 → Mode: Text → Action: Send. 
 Name: FwD (Forward) → Value: 5 → Mode: Text → Action: Send. 
 Name: BwD (Backward) → Value: 6 → Mode: Text → Action: Send. 
 Name: Stop → Value: 7 → Mode: Text → Action: Send. 

3. On Pedro, set the switch AT → BT to: BT. 
4. Pair your device with Pedro’s HC-05 module (default name: HC-05, PIN: 1234). 
5. Use the app buttons to send commands and control Pedro in real time. 

 🛠️ AT Mode Setup (Optional – change Pedro’s Bluetooth name):

1. Power OFF Pedro. 
2. Set switch NRF → BT → WiFi to: BT. 
3. Set switch BT → AT to: AT. 
4. Power ON Pedro. 
5. Enter the BLUETOOTH UPDATE menu. 
6. Change Pedro’s Bluetooth name (e.g., from PEDROROBOT1 up to PEDROROBOT99). 
7. Pair your device with the new name (PEDROROBOTX). 
8. Use the app buttons to control Pedro as before. 
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3. Quiz (20 Questions)

1. Which component of the Pedro board is considered the “brain”?
A) OLED display 
B) ATmega32u4 microcontroller 
C) Servo motor 
D) Battery

 Answer:✅

2. The OLED screen size on the Pedro board is:
A) 64×32 
B) 128×64 
C) 16×2 
D) 320×240

 Answer:✅

3. Manual Mode allows control via:
A) Smartphone app 
B) Onboard buttons 
C) Voice commands 
D) Radio link

 Answer:✅

4. In Record & Replay Mode, you must first:
A) Upload code 
B) Move the robot manually 
C) Change battery 
D) Connect to WiFi

 Answer:✅

5. Bluetooth Mode on Pedro uses which module?
A) ESP8266 
B) HC-05 
C) NRF24L01 
D) GPS

 Answer:✅

6. Radio Mode enables communication between _________ robots.
A) Two 
B) One 
C) Three 
D) Four

 Answer:✅

7. USB Serial Mode uses the port to _________.
A) Print 3D parts 
B) Upload code or send commands 
C) Charge the battery 
D) None of the above

 Answer:✅

8. The slide switch for communication modes is labeled _______.
A) POWER 
B) NRF → BT → WiFi 
C) MODE 
D) COMM

 Answer:✅
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9. The Code key in Radio Mode ranges from _______.
A) 0-9 
B) 1-99 
C) 100-999 
D) 0-255

 Answer:✅

10. What module enables WiFi on Pedro?
A) HC-05 
B) NRF24L01 
C) ESP8266-01 
D) MPU6050

 Answer:✅

11. The ATmega32u4 allows programming via which IDE?
A) Eclipse 
B) Arduino IDE 
C) Visual Basic 
D) MATLAB

 Answer:✅

12. What is the purpose of the RX/TX pins?
A) Power servos 
B) Serial communication 
C) Download STL files 
D) Print 3D parts

 Answer:✅

13. « No tools required » means the kit is ___________.
A) Pre-assembled 
B) Tool-free assembly 
C) Only screws 
D) Requires soldering

 Answer:✅

14. The primary learning domain for these modes is ___________.
A) History 
B) STEM 
C) Art 
D) Geography

 Answer:✅

15. « Hands-on STEM learning » promotes ___________.
A) Watching videos 
B) Building and experimenting 
C) Reading books only 
D) Using simulators

 Answer:✅

16. Open-source hardware allows students to ___________.
A) Disassemble parts only 
B) View, modify and share designs 
C) Keep designs proprietary 
D) Use closed software

 Answer:✅

12 / 13
Pedro STEM Lesson n°2                                                                                                                   https://pedrobot.com

https://pedrobot.com/


17. Which mode is best for directly recording manual movements?
A) Manual Mode 
B) Record & Replay Mode 
C) Bluetooth Mode 
D) USB Serial Mode

 Answer:✅

18. Pedro’s 3D missing parts can be found on _________.
A) Facebook 
B) GitHub 
C) Instagram 
D) Pinterest

 Answer:✅

19. The educational value of Multiple Modes is to show _________.
A) Only one type of control 
B) Diverse control interfaces 
C) Just electronics 
D) Only mechanics

 Answer:✅

20. In Radio Mode, both robots must use the same _________.
A) Battery level 
B) Serial port 
C) Code Key 
D) USB cable

 Answer:✅

END
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